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BrightAuthor presentation files (.bpf files) created on one computer may fail to open on another computer due to the language that the operating system is set to. Verify the operating systems on both computers are set to the same language, change the language to English temporarily, then try to open the presentation file in BrightAuthor. For example:

Action

You attempt to cast a numeric string to a numeric data type, using code similar to the following:

Code Block
Dim strInput As String = "10"
Dim intResult As Integer = 0
Try
  intResult = Convert.ToInt16(strInput)
  Catch ex As Exception
  MessageBox.Show("Error: " & ex.Message)
End Try

Result

You receive a System.FormatException with "Input string was not in a correct format" and this stack trace:

Code Block
A first chance exception of type 'System.FormatException' occurred in mscorlib.dll
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at System.Int16.Parse(String s, NumberStyles style, NumberFormatInfo info)
at System.Convert.ToInt16(String value)
at TypeConversionTest.Form1.cmdConvert_Click(Object sender, EventArgs e) in C:\Source\TypeConversionTest\TypeConversionTest\Form1.vb:line 7

Cause

There is an incorrect value in the following value in the Windows registry:

HKEY_CURRENT_USER\Control Panel\International\sPositiveSign

This value should be empty for most English Language settings. Note that when this error occurs, the value may appear empty visually, but may contain a space or unprintable character.

Resolution

While it is possible to directly edit the value for the problem key, the preferred method is to change the Regional Settings to a different Region/Language and then reset it to the desired setting:

  1. Open the Regional and Language Options applet from the Control Panel.

  2. Note the Current Format.

  3. Change the Current Format to "English (Australian)".

  4. Click Apply.

  5. Change the Current Format to the desired format (for example, "English (American)").

  6. Click Apply and then click OK.

This action resets every value under the HKEY_CURRENT_USER\Control Panel\International registry key.

How can I troubleshoot my BrightAuthor Local File Network setup?

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  • By default, BrightAuthor uses Bonjour to automatically discover BrightSign players on the local network. If either Bonjour or BrightAuthor is blocked by your firewall software, then discovery won’t work. Bonjour is sometimes listed as "mdnsResponder" and uses UDP port 5353. It's also possible this is just a temporary issue; the list often takes a few seconds to refresh after after you select the Publish > Local File Network or Manage > Local Network tabs.

  • If BrightAuthor has Bonjour enabled (which it is by default), ensure the Bonjour service is running in Services.

  • Update Bonjour.  If it's already installed, uninstall it and reboot, then reinstall it.
    The Apple AirPort Utility includes Bonjour.  You can uninstall Apple Software Update and the AirPort applications after it completes installing, just leave Bonjour.
    https://support.apple.com/downloads/air%2520port%2520utility%2520windows

  • Verify that you are using the latest version of BrightAuthor software and OS for your player (see the Downloads page).

  • Verify that the SD card is inserted into the player and has not been manually edited since Device Setup. There is a program installed on the card during player setup that listens to publish requests from BrightAuthor.

    • If you run setup, then remove the SD card and publish a local presentation to it, you won't be able to add the player to BrightAuthor.

  • Perform the Device Setup process again.

  • Verify that you don’t have an active VPN connection. Local File Networking is only supported on the same subnet.

  • Make sure that your firewall software is not blocking connectivity between BrightAuthor and the player.

  • Disable proxy settings in Internet Explorer.

  • Hit the refresh button on the Publish > Local File Network or Manage > Local Network tab.

  • Leave the Publish or Manage tab, then return.

  • Add the player manually using the player IP address.

  • Some antivirus software that includes network components can block Bonjour (e.g., Kaspersky antivirus). Try temporarily disabling that software or add BrightAuthor as a trusted application.

  • Local File Networking is not supported on Windows XP.

  • Local File Networking supports a maximum of 10 players on a local network. Exceeding this recommended number may cause unreliable behavior when publishing to players. For larger deployments, we recommend using the Simple File Network or BrightSign Network publishing methods instead. 

If automatic discovery isn't working, try adding the unit manually. In BrightAuthor, navigate to Publish > Local File Network, click the Add icon under Publish, and enter the IP address of the player.

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